1. Home
  2. Docs
  3. WPS Player
  4. Troubleshooting
  5. The quality switcher doesn’t show up

The quality switcher doesn’t show up

With my own videos

There are only a few special cases for the quality switcher to be displayed.

Be sure to be in one of these cases:

  1. You are using a theme from WP-Script:
    1. Add a new video.
    2. Upload and/or fill at least 2 different resolutions urls in the video resolution fields.
    3. Each resolution url must be unique (don’t use the same video link for two or more resolution fields).
  2. You are using the WPS Player Shortcode:
    1. Add at least 2 different resolutions parameters (ie. 720p and 1080p)
    2. Each resolution url must be unique (don’t use the same video link for two or more resolution fields).

In any other case, the quality switcher may not be displayed.

With videos from Adult Tubes

Important: We do not recommend to use the Adult Tubes transformation options. We can’t assure that it will work on your site. Even if it is working, it can stop working from one day to the other.

By default, WPS Player will display tubes default iframe with their embed ads and redirections. But the “Before Play” ads and your logo you’ve set up in the options will still show up over the default tube iframe.

That said, WPS Player integrates some options to transform the following tubes iframes:

  • Redtube iframes
  • Xvideos iframes
  • Youporn iframes
  • Youporn Gay iframes

When those options are activated, the WPS Player will try to display the original MP4 of the videos instead of the tube iframe.

When multiple resolutions of the same mp4 can be found, WPS Player will display the quality switcher. In all other cases it won’t.

Any other videos iframes from other tubes won’t even be transformed.

Was this article helpful to you? Yes No